• 没事点点广告,也是对博主的支持,谢谢!
  • 本站提供丰富的素材下载,有源码、模板、插件...
  • 内容如有侵犯,请立即联系管理员删除
雷小天博客

首页  > 说说  > 报错  

python升级后yum报错:File "/usr/bin/yum", line 30

当我们输入任何yum命令,都会报错。原因是升级python后,导致yum所需版本不一致导致!

如何解决python升级后yum报错

如图,我将python版本编译安装python3.3.0。将3.3链接到/usr/bin/python.

如何解决python升级后yum报错

我们查看/usr/bin/yum 文件,可以看到,yum调用的是/usr/bin/python这个文件。所以改变之后就会报错。

如何解决python升级后yum报错

这个时候我们只需要修改yum配置文件,将python版本只想以前的旧版就可以了。

#vi /usr/bin/yum

因为我的旧版本是2.7,所以将#!/usr/bin/python改为#!/usr/bin/python2.7就可以了!

退出保存

如何解决python升级后yum报错

再次运行yum命令,就不回再报错了。

如果运行后报以下错误File "/usr/libexec/urlgrabber-ext-down", line 28    except OSError, e:

就修改/usr/libexec/urlgrabber-ext-down文件,将python同样指向旧版本,就可以了

如何解决python升级后yum报错



当前共有0留言发表留言

我要留言 / 展开表单

  • 审核开启
  • 记住信息
  • 邮件回复

选择风格关闭

取消 雷小天博客